Acura RSX, ILX and Honda EP3 Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So obviously someone just posted about a heater issue, but the HVAC System was redesigned for the ‘05-‘06 models it seems, plus my problem is a little different. So I recently had my AC system looked at, and they replaced my condenser fan and recharged the system and everything, but when I got the car back from my mechanic they said they had no idea why my heater wouldn’t work. So I did some research and did some tinkering and came up blank. My AC blows cold and works fine, which is a real blessing in sunny San Diego, but the mornings and nights drop to low 50’s and high 40’s sometimes, so I need my heat. When I switch to anything warm, my AC blows cold as if it was still set to cold. It properly switches between the different vents and defrosters, but never seems to get hot or anything. My cooling system is running as it should, and my blower motor and resistor seem to be functioning as they should. I’ve also looked at the switch by the back firewall that supposedly controls the AC to let in warm air, but after switching my heat on/off and even trying to physically move the switch myself, the thing doesn’t seem to budge. I’m kinda at a loss. I have noticed something at night, however. The AC Controls are illuminated at night, but when moving the dials, the lights for the right most dial are not lit, and won’t come back on. Is my whole control unit bad, maybe a bad wire or a blown fuse? Or is it that switch in the engine bay just gone bad? All and any input is appreciated.
Thanks,
Jeff
 
1 - 1 of 1 Posts
Top