Acura RSX, ILX and Honda EP3 Forum banner

1 - 20 of 62 Posts

·
Registered
Joined
·
1,953 Posts
75 pages, I skimmed and couldnt find what Im looking for. I wired my 1st stage up last wednesday, I have been unable to make it work. I wired system up per diagram on Hondata's website. My arming is using B9, and then the other wire going to a ground. My output is using B6 going to the grounds of my solenoids, and then the rest is wired like Hondata and on here. I tested this setup by touching the grounds from the solenoids to a ground and they clicked open, so I know that far is working. So the issue is where that goes into the ECU and/or the other wire that goes to the toggle. I can invert switch and it stays on all the time though.

Also, Im gonna piggy back off this cause I have a feeling if someone answers this question I can figure out why my launch control doesnt work either. If I use E29 to a toggle to the clutch switch( Im gonna x that and use a micro switch to a ground now) it dont work either, but I invert switch and it stays on all the time.


I emailed Hondata, but that was useless, Hondata Customer Service FTL, they just said if it was too difficult for me to go to a shop that knows how. They answered my question like a politic, they did everything but answer it, haha. Its not that hard to do, its just Im missing something here, something soo simple. What is everyone doing for their nitrous through Kpro to get the wiring to work?
 

·
doesn't even have an RSX
Joined
·
28,924 Posts
Discussion Starter #3
PM exactly where your wires are running; all of them.
Sounds like you're fucking something up.
 

·
Registered
Joined
·
1,953 Posts
Thanks man, PM sent


Here is exactly how I wired it...

http://www.hondata.com/techkpronitrousdiagram.html
On arming I used B9, and on output I used B6 though

Here is how we have it listed on here, only difference I see is that the toggle goes to positive on ClubRSX instead of ground like Hondata.

 

·
Registered
Joined
·
408 Posts
Goal: I want to run a small wet shot that sprays not by WOT (tapping into the ecu/wiring), but by a push button that I hold when I want to spray and release when I'm done

Question: How would I wire that up? (i already know about the arming safety switch) Would I still have to tap into the ECU?
 

·
Got Juice??
Joined
·
792 Posts
Goal: I want to run a small wet shot that sprays not by WOT (tapping into the ecu/wiring), but by a push button that I hold when I want to spray and release when I'm done

Question: How would I wire that up? (i already know about the arming safety switch) Would I still have to tap into the ECU?
Yeah you can hook it up like that, its how mine is done. Just run the wires of the solenoids to a power and a ground and put the botton and safety switch in between the wire somewhere.
 

·
Registered
Joined
·
408 Posts
Yeah you can hook it up like that, its how mine is done. Just run the wires of the solenoids to a power and a ground and put the botton and safety switch in between the wire somewhere.
so far you've answered every ? I've had about nitrous..thanks a lot!:thumbsup:
 

·
Registered
Joined
·
1,953 Posts
ok, I figured out one issue, now another. I swapped my B9 to E22 and wired toggle just like CRSX says. When I hit it first, it popped the 7.5a fuse I had it in, I was sharring that with my tach, the meter fuse. I switched fuses to a 10a for the nitrous. Also, my tuner looked at my relay, and noticed that my buddy wired it up exactly backwards of CRSX/hondata, so we changed that around. Kpro showed nitrous was then armed when switched on. Next issue, we did our pull, showed it was spraying, but we didnt spray anything. Tried 3 more pulls and nothing, and we know the fuel wasnt spraying cause it didnt go pig rich, I didnt pull any timing, and made same hp and trq as NA. We pulled line off and tested it and nothing, then we snipped the wire from 85 and tested it by touching to a ground, and the solenoids fired off. Apparently B6 isnt giving it a good ground or something, true? Should I just go ahead and swap to E21?
 

·
Registered
Joined
·
1,953 Posts
Oh yeah, another guy working on a car behind us noticed when the nitrous activated the brake lights came on, is this normal, if so that is retarded, how do I stop that?
 

·
doesn't even have an RSX
Joined
·
28,924 Posts
Discussion Starter #12
Sorry I didn't get to PM you back.
I would definitely switch tom pins
E22 and E21.
 

·
Registered
Joined
·
1,953 Posts
lol, be funny, my tuner was laughing saying after I beat someone "yeah and I was riding my brakes while smoking your ass too!" haha. Its fine, jsut I dont want to look retarded going down the track with brake lights on.
 

·
Registered
Joined
·
59 Posts
Hey guys, I'm running a wet 50 shot for my type s with an aem cai, megan race headers, and , a skunk 2 exhaust,and i just ran a crx with a h22 swap and got beat by 2 or 3 cars. when i hit nitrous i felt my vteck lag alot, like there wasnt enough power there. if i ran all motor i think i would have been better off, do you guys think it has anything to do with where i drilled the hole on the intake for the nitrous? i drilled the hole even with the termperature gage and i think that wasnt very smart.. anyways i was just wondering if i can get any input on what went wrong.. or if the b20 was just fast as hell.
 

·
Registered
Joined
·
1,953 Posts
also, can you datalog to see your AFs? And are you sure it was spraying, Im having an issue with mine not spraying, and if your dry shot that means your Kpro is dumping fuel in and no nitrous. Or bottle pressure, one of the two Im sure. And what do you mean even with the temperature gauge?
 
1 - 20 of 62 Posts
Top