Acura RSX, ILX and Honda EP3 Forum banner
1 - 20 of 41 Posts

·
11.6 @ 123mph
Joined
·
2,303 Posts
Discussion Starter · #1 ·
So I was on the highway and I noticed my battery light was flickering. I pull over and check the battery cable, everything is okay. I start driving again and its still there. When I accel. it goes away and then comes back on the decel. Think this is an alternator problem?
 

·
11.6 @ 123mph
Joined
·
2,303 Posts
Discussion Starter · #3 ·
ive replaced the serp. belt prob like 4k miles ago. the motor has 8k on it and the alt 22,000 miles. seems way to early for something like this.
 

·
Big Pimpin
Joined
·
15,710 Posts
ive replaced the serp. belt prob like 4k miles ago. the motor has 8k on it and the alt 22,000 miles. seems way to early for something like this.
could be the battery itself isn't pushing out the right voltage at lower rpm's. Just sounds to me like the alternator isn't pumping out enough juice at lower rpm's. I see you're S/C, but do you have like lighter pulleys or anything like that?
 

·
11.6 @ 123mph
Joined
·
2,303 Posts
Discussion Starter · #7 ·
my car isnt s/c'd its turbo. i have an odyssey battery but have never had problems with it. I will check the belt tension.
 

·
Shiny side up!
Joined
·
930 Posts
Get a multimeter out ,and check the volt reading at the battery to see what it's charging. See if it is dropping below 12volts at idle (especially if the battery light is on).
 
G

·
Yep, voltmeter. If it's not belt tension, it has to be the alternator. Oh, just a thought: have you checked your ground cables lately, since you have a different battery? Good battery + good alternator + bad ground = dying battery/ possible misdiagnosis. Good luck for a speedy fix.
 

·
I can drive up your rsx
Joined
·
29,087 Posts
Get a multimeter out ,and check the volt reading at the battery to see what it's charging. See if it is dropping below 12volts at idle (especially if the battery light is on).
You don't want your idle voltage to go below 13.5
 

·
I can drive up your rsx
Joined
·
29,087 Posts
A big concern with lower than 13.5 voltage is that the Fuel Pump isn't getting the full power it wants and will actually lean u out.
 

·
11.6 @ 123mph
Joined
·
2,303 Posts
Discussion Starter · #17 ·
kpro reads 14.3 volts. belt tension is fine. i dont think its the altenator i believe it may be some sort of loose connection. kpro takes care of me leaning out :) lean cut baby.
 

·
Love ///My new car
Joined
·
2,725 Posts
alternators reach full electrical "boost" at like 1500rpm. my thought is maybe your battery tray is rocking either forwards or backwards hurting a connection to throw on the battery light. you did check both positive and negative terminals right. maybe a wire got slightly cut from some ic piping rubbing it inbetween some part of the engine or who knows and your engine physically rocking in your motor mounts is grounding/ungrounding depending on its position:dontknow:
 
1 - 20 of 41 Posts
Top