Acura RSX, ILX and Honda EP3 Forum banner

21 - 40 of 68 Posts

·
Registered
Joined
·
8,955 Posts
So how do you set the readiness?? Like i click on set readiness but nothing happens please help.
What do you expect to happen? Any existing DTC's will be cleared from the Error Codes window (Windows | Error Codes) and the status will be set to pass for the supported tests. Of course, the ECU repeats these tests eventually, so the DTC for no cat will come back.

Oh, and you need to have the ignition in the On position. Set Readiness is not a save-and-upload sort of command; it is a live command.
 

·
Registered
Joined
·
13,797 Posts
& set readiness just before showing up for inspection too.
 

·
Registered
Joined
·
13,797 Posts

·
Registered
Joined
·
8,147 Posts
i have been exempt from emissions the past two years but probably will not be able to pull it off next year if i move. so i am going to give this a try too.
 

·
Car Is Sold!
Joined
·
6,315 Posts
I passed with a faulty o2 sensor. It's been disabled on the last emissions test I had done. We have to turn our engine off for our emmissions testing. I forgot to enable my OBDII and forgot to set readiness.
 

·
Registered
Joined
·
120 Posts
I don't think the ecu resets with the ignition off. with the battery unhooked, yes. I personally am a texas state inspector and from my two years of experience of inspections, there are tactics around the inspection systems.
 

·
asdf
Joined
·
2,373 Posts
I just passed my emissions with a bad secondary O2 sensor (threw a P0420, which is what you'd get with a race header/no catalyst convertor). So I enabled ODBII and Set Rediness the night before I went. All they did was plug into OBDII and run some scan, I passed. On the drive home my CEL went back on. :shady:
 

·
I can drive up your rsx
Joined
·
29,088 Posts
I just passed my emissions with a bad secondary O2 sensor (threw a P0420, which is what you'd get with a race header/no catalyst convertor). So I enabled ODBII and Set Rediness the night before I went. All they did was plug into OBDII and run some scan, I passed. On the drive home my CEL went back on. :shady:
If they hooked a sniffer to your tail pipe u would have failed.
 

·
GF in the avy
Joined
·
478 Posts
sorry i dont mean to jack ur thread or anything but Im having a huge problem. after i got the DCRH, i had the cel. i assumed it was cuz of no cat. so i used a defouler + o2 sim. but with more investigation it told us that the heat something was messed up in the sensor. so the sensor was bad. but after trying another 2 sensors, still the same problem. my mechanic said hes getting a strong + and - current but a weak ground. and he said theres good continuity throughout the wire so its not a snip or break in the wires. any clue as to what it could be?
 

·
Jurassic Member
Joined
·
4,023 Posts
sorry i dont mean to jack ur thread or anything but Im having a huge problem. after i got the DCRH, i had the cel. i assumed it was cuz of no cat. so i used a defouler + o2 sim. but with more investigation it told us that the heat something was messed up in the sensor. so the sensor was bad. but after trying another 2 sensors, still the same problem. my mechanic said hes getting a strong + and - current but a weak ground. and he said theres good continuity throughout the wire so its not a snip or break in the wires. any clue as to what it could be?
Primary 02? I am having the same issue. They say it could be a bad ECU. Hondata told me to update the software and clear security then upload the tune again. If it still does not work it's probably a bad ECU. I don't think it' is though. My car seem to run just fine so I think it is a software glitch because mine did not start until I updated the software and changed the tune. Then it gave me problems and i can't set rediness now.
 

·
2night I wear a small hat
Joined
·
8,649 Posts
Sorry to bump an old thread but I have a question about setting the readiness. When I selected it nothing happens and in the error codes box under readiness codes it says not supported and for status it has (-) marks. Is this supposed to happen. I have an 05. Can anyone help? thanks
 

·
2night I wear a small hat
Joined
·
8,649 Posts
Nope it is enable
 
21 - 40 of 68 Posts
Top