Acura RSX, ILX and Honda EP3 Forum banner
61 - 72 of 72 Posts

·
Registered
Joined
·
139 Posts
you should be able to make them n/a also, meaning the obd2 test wont check any of them, because the ECU is telling the inspection station there is nothing to check, my buddy does this with his evo when i inspect it for him.
Is there any tutorial on that? I mean I was also informed that clearing DTC codes then setting readiness will also help the process but not 100% Guaranteed.
 

·
Registered
Joined
·
6,757 Posts
Since you don't have any CEL's, I don't think clearing the DTC codes will do anything.
 

·
Registered
Joined
·
54 Posts
please noone say search because i have. k pro is now 4.4.4 and I checked all the information i could and all i can find is the set readiness on ECU for emissions after clearing the DTC's. however these are all old posts and older versions of k pro. I have had my rsx turbo'd since 2014 i believe and recently moved to a county that does e check. The evap is turned off due to the skunk2 manifold and the P0134 is turned off and my secondary O2 is capped off at the moment. i can have one fault code in my county so the evap will be obviously that so im going to try to find my secondary O2 and do the defoulder method and see if that works for the secondary code after enabling. in other words am i missing something with this set readiness option in the newer version of K pro or is that eliminated? At the end of the day my dad said if all else fails i can transfer the car to him. I dont really want to do that since we use the same insurance company and they think i drive a stock unmodified machine and then might question.
 

·
Registered
Joined
·
54 Posts
please noone say search because i have, bringing the thread back from the dead. k pro is now 4.4.4 and I checked all the information i could and all i can find is the set readiness on ECU for emissions after clearing the DTC's. however these are all old posts and older versions of k pro. I have had my rsx turbo'd since 2014 i believe and recently moved to a county that does e check. The evap is turned off due to the skunk2 manifold and the P0134 is turned off and my secondary O2 is capped off at the moment. i can have one fault code in my county so the evap will be obviously that so im going to try to find my secondary O2 and do the defoulder method and see if that works for the secondary code after enabling. in other words am i missing something with this set readiness option in the newer version of K pro or is that eliminated? At the end of the day my dad said if all else fails i can transfer the car to him. I dont really want to do that since we use the same insurance company and they think i drive a stock unmodified machine and then might question. I updated some options and I got 3 of the 4 completed. In theory the systems are ready and this should pass yes?
 

·
Registered
Joined
·
54 Posts
please noone say search because i have. k pro is now 4.4.4 and I checked all the information i could and all i can find is the set readiness on ECU for emissions after clearing the DTC's. however these are all old posts and older versions of k pro. I have had my rsx turbo'd since 2014 i believe and recently moved to a county that does e check. The evap is turned off due to the skunk2 manifold and the P0134 is turned off and my secondary O2 is capped off at the moment. i can have one fault code in my county so the evap will be obviously that so im going to try to find my secondary O2 and do the defoulder method and see if that works for the secondary code after enabling. in other words am i missing something with this set readiness option in the newer version of K pro or is that eliminated? At the end of the day my dad said if all else fails i can transfer the car to him. I dont really want to do that since we use the same insurance company and they think i drive a stock unmodified machine and then might question.
 

·
Registered
Joined
·
54 Posts
Well I changed settings a mile down road from self kiosk then had my blue tooth tool connected and right when they all hit ok before it could throw a code I scanned it and it worked. Hope this may help someone in 2020 if they are searching. All systems were complete but evac.
 

·
Registered
Joined
·
54 Posts
I basically unchecked anything that disabled a code. After doing that I just kept it plugged in and reset dtc's. As the car idled the systems just started clicking to completed, unlike a standard ecu like in my wrx. In really minutes of reset the systems were moving to completed after the car was warming up. In OH you can have one system not running and that was going to have to be my evac and it wasn't throwing the code yet. I pulled into a parking lot down the street from the self test, did reset and as they clicked over and I plugged my Bluetooth reader in and kept readiness up to make sure it stayed not completed on evac then plugged it in real quick and passed. After I left shortly after it tossed the code and then reflashed with it all turned off when I got back home. Hopefully this will be similar for you and hope this helps you and anyone else out there that reads this!
 

·
Registered
Joined
·
4 Posts
I basically unchecked anything that disabled a code. After doing that I just kept it plugged in and reset dtc's. As the car idled the systems just started clicking to completed, unlike a standard ecu like in my wrx. In really minutes of reset the systems were moving to completed after the car was warming up. In OH you can have one system not running and that was going to have to be my evac and it wasn't throwing the code yet. I pulled into a parking lot down the street from the self test, did reset and as they clicked over and I plugged my Bluetooth reader in and kept readiness up to make sure it stayed not completed on evac then plugged it in real quick and passed. After I left shortly after it tossed the code and then reflashed with it all turned off when I got back home. Hopefully this will be similar for you and hope this helps you and anyone else out there that reads this!
I just got kpro v4 and I’m trying to figure it out , I see what you meant by there being no “set readiness” option, but I still don’t understand how you got yours to come on and be “completed” because currently I don’t have any dct codes and honesty I’m not sure if the obd2 is enabled or disabled , I plugged in my obd2 scanner and it read that 3 monitors were ready and 4 were not ready , so maybe the obd2 is enabled , Idk , and when I’m on kmanager and go to the error tab , the readiness has nothing listed under it , it’s just blank, where is the enable/disable obd2 function ?
 

·
Registered
Joined
·
54 Posts
I just got kpro v4 and I’m trying to figure it out , I see what you meant by there being no “set readiness” option, but I still don’t understand how you got yours to come on and be “completed” because currently I don’t have any dct codes and honesty I’m not sure if the obd2 is enabled or disabled , I plugged in my obd2 scanner and it read that 3 monitors were ready and 4 were not ready , so maybe the obd2 is enabled , Idk , and when I’m on kmanager and go to the error tab , the readiness has nothing listed under it , it’s just blank, where is the enable/disable obd2 function ?
I can't really remember off hand but I'm pretty sure there was a box in one of the tabs, maybe closed or open loop. I'm def no expert on the k manager, but I just let the car sit there and idle and was just looking in the tabs for things to help me for inspection, came back to readiness monitors and more kept clicking over to completed. It was really weird I'm not gonna lie. Once I saw what was happening I ran inside yelled I'll be back and reset and drove down the street to the self kiosk and reset accross the street, let it idle and plugged in when stuff said complete. My subie I had to take off cobb tune, get the plug defouler on secondary, resistor for egr, and all this other stuff and drive around forever. And the one I figured that would be more troublesome I let the thing idle and it said completed, no secondary O2 sensor even in the car. Plugged and 3in from turbo all the way back. I really wish I could help you more on this one especially if inspections are sooner than later. Can try letting it idle longer. I went cold start to it fully warmed up and time after.
 
61 - 72 of 72 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top