Acura RSX, ILX and Honda EP3 Forum banner
1 - 20 of 35 Posts

·
U mad bro?
Joined
·
1,034,606 Posts
Discussion Starter · #1 ·
I bought a replica mugen rear strut bar, finally got around to install it today, i have the plastic molding all cut away.

went to bolt the one side up, everything went fine... went to the 2nd side, got the top bolt in, then spent about 3 hrs trying to get the bottom bolt to go in.

ive tried everything: longer bolts, jacking the car at every jacking point, tried cutting the holes in the strut bar just a bit bigger (that didnt go well because my drill didnt do shit to the bar).... the bottom one is going in too much at an angle for the threads to grab.

wtf am i missing something? i couldnt get this damn thing on to save my life.

:firemad: :firemad: :firemad:
 

·
Registered
Joined
·
482 Posts
I had to thread them each a little at a time so no one side was tighter than the other. It was a pain for me too.
 

·
U mad bro?
Joined
·
1,034,606 Posts
Discussion Starter · #3 ·
I had to thread them each a little at a time so no one side was tighter than the other. It was a pain for me too.
yeah, first i put the one side on, both bolts were on, not tightened...

then i did the other top one, it went on, didnt tighten that one either. went to go put the bottom one on and it wont thread.

ive taken bolts off and tried that, tried starting on the other side and still same thing.

for those of you who installed this, what jack point did you jack up in order to line everything up, and what side were you trying to bolt up?
 

·
SiK DC5
Joined
·
9,689 Posts
unbolt the whole bar and do the bottom bolts first just enough to hold the bar.. then do the top ones on each side. Once you have them all in a lil' bit.. tighten' up the bottoms halfway, then the top ones.. then do the bottoms all the way and then the tops. Get it? hope that helps... i'll be doing mine this weeks
 

·
U mad bro?
Joined
·
1,034,606 Posts
Discussion Starter · #6 ·
unbolt the whole bar and do the bottom bolts first just enough to hold the bar.. then do the top ones on each side. Once you have them all in a lil' bit.. tighten' up the bottoms halfway, then the top ones.. then do the bottoms all the way and then the tops. Get it? hope that helps... i'll be doing mine this weeks
ive already tried that... the tops line up fine, i can put both in, then i can put one side bottom in and it fits, the last one just doesnt wanna catch.

i tried starting with both bottoms and i get the same problem.
 

·
U mad bro?
Joined
·
1,034,606 Posts
Discussion Starter · #8 ·
try to get a friend help you w/ the install...mine was a bitch and a half to get in :(
my dad actually stopped by when i was in the middle of it and tried helping, he suggested getting longer bolts. so i did and it didnt help, he tried yankin on the bar while i put the bolts in and still nothing..

i need to twist my cars body some how to get that bolt to line up

dorkzracing: GL on the install, hopefully yours goes easier than mine haha
 

·
Registered
Joined
·
113,845 Posts
try jacking up the car at different points to see if you can get it installed that way before you go try using air tools
 

·
U mad bro?
Joined
·
1,034,606 Posts
Discussion Starter · #12 ·
try jacking up the car at different points to see if you can get it installed that way before you go try using air tools
i already tried that and didnt see any movement. i was trying to install the driver side and tried jacking that side up, and then tried jacking the other side up as well and still nothing :confused:
 

·
Registered
Joined
·
113,845 Posts
i already tried that and didnt see any movement. i was trying to install the driver side and tried jacking that side up, and then tried jacking the other side up as well and still nothing :confused:
did you have a 2nd person there? have one inside trying to get the bolt in and one outside with the jack trying different jack points...
 

·
aka Batman on weekends
Joined
·
1,677 Posts
i would suggest getting a dremel with a sanding tip and making all 4 holes on the strut bar a little bigger- but not too big that the bolt falls thru. thats what i ended up doing and it finally fit. Rear mugen strut is a bitch though - everyone goes throught this with the replica
 

·
Registered
Joined
·
113,845 Posts
yeah, thats what my dad helped me with when he stopped by.

i never thought a rear strut bar would be this damn difficult lol :mad:
not the rear tower bar...the replica

my authentic fit like a glove :thumbsup:
 

·
Weightlifting Master
Joined
·
3,311 Posts
wow either you got a messed up replica or somethings wrong with your chassis :noes: lol jk the replica might be a bad one from the batch, mine didn't match up the best but still was pretty easy to install, just get all 4 bolts hand threaded in then start tightening them a little at a time, kinda like doing the subframe bolts.
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top