Acura RSX, ILX and Honda EP3 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3,501 Posts
Discussion Starter · #1 ·
I can't seem to get my engine light off... anyone have a DIY instructions or know where i can find some? i'm starting to think my o2 sensor is gone! :mad:

Thanks,

D
 

·
Ebay Whore
Joined
·
1,588 Posts
have you tried removing the fuse? or negative terminal of battery? if you can't get rid of the CEL, you could have put the o2 sim in backwards, and there's a possiblility it could have messed your ECU up. Similar situation happened to me and i had to get a new ecu, once i got new ecu, i reinstalled the sim and no CEL now.
 

·
Registered
Joined
·
3,501 Posts
Discussion Starter · #3 ·
how do i tell if i need a new ecu?? how much does one of those cost?

D
 

·
yawn..
Joined
·
22,903 Posts
Got my sim and race header sitting at home right now... install pending...
 

·
Registered
Joined
·
3,501 Posts
Discussion Starter · #6 ·
lemme know how u install ur sim please!

D
 

·
Registered
Joined
·
707 Posts
D Fabulous said:
lemme know how u install ur sim please!

D
I installed my Caspers o2 sim at the same time as my JR race header. After install, first startup I got the CEL. I pulled the backup fuse to reset the ECU, left if off for at least a minute. Plugged it back in, started up the car and the CEL was gone. I've driven a good 3-4000 miles since with no problems.
 

·
Registered
Joined
·
3,501 Posts
Discussion Starter · #8 ·
so how did u connect it? which plugs where? thanks,..

D
 

·
Registered
Joined
·
707 Posts
D Fabulous said:
so how did u connect it? which plugs where? thanks,..

D
There's 2 - o2 sensors. Front sensor is a black wire, rear sensor is a white wire. You want to hook up the o2 sim to the rear sensor. Double-check the connections, and if you're still getting a CEL then reset the ECU.
 

·
Registered
Joined
·
3,501 Posts
Discussion Starter · #10 ·
thanks for the info man that is exactly what i needed... when i get my car back from the shop i will try it out if not then i guess i might have messed up the o2 sensor grrr...i think they are expensive too...

D
 
1 - 11 of 11 Posts
Top