Acura RSX, ILX and Honda EP3 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Hey guys, have a CAI, nothing else, and I had a hydrolock scare.

Anyways, both codes deal with the Air/fuel sensor. Compression test came back fine, no problems there. I would prefer not to have to buy a new A/F sensor.

Any tips ideas for cheap fixes? IAT looks fine. What else can I check or clean?



BTW:
car stalled in rainy conditions
oil was fine, no water
compression fine


Thanks,
Pedro
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #3 ·
1172 is a manufacturer code for the a/f sensor. i know it was not listed on the codes breakdown, but I remember that it dealt with parameter malfunction or somesort.

basically, the air/fuel sensor is fried methinks.


LOOKING FOR A AIR/FUEL SENSOR for a 2006 type s now.

-pedro
 

·
Currently High.
Joined
·
790 Posts
ya thats why i said fuck a CAI, i had to buy a PRC manifold cuz of that shit.
 

·
Why don't YOU slow down?!
Joined
·
10 Posts
I had the same exact thing happen to me. Random storm + no street lights + large low spot in the street = car stallin, heart skipping, and hydrolock scare.
P2A00 = 02 Bank 1 Sensor 1 Range/Performance
P1172 = Manufactor Controlled Fuel & Air Metering
When I went to the dealer the have them chec' it out when it first happened they tried to BS me big time. I mis-shifted once fuc'in around and I forgot that the damn comp stores that shit. Well they tried to tell me that I got the codes as a result of the mis-shift and that there could be a vavle stuc' or something. Of cousre I didn't tell them what happened in the rain. By this point I was curious what the hell they were gonna tell me next. They tried to bully me into leaving my car there, having the manufactor take my engine apart, "fix" it, and they would "help" me by paying half of the cost. They obviously thought they were dealing with someone that didn't know shit about cars and was a fuc'in idiot. I made them have the tech show me the codes and then explain them to me.....then explain why I would have to take the engine apart from reading those codes. Well...they failed miserably. I wish I had a tape recorder cuz I would have certainly sent it to the news station it was so bad. Needless to say fuc' the dealer...they were doing good until then. So now I'm trying to figure out what exactly to do...from everything that i have seen so far it looks like the primary sensor is either not seated properly, has faulty wiring, or is just basically fried.
 

·
Name's Vic
Joined
·
14,753 Posts
sounds like you need a primary o2 sensor, you might have had no water in the car but you might have had enough that it smoked white burning off water and smoked your o2 sensor.

Now if you go to a dealer and change your CAI to your stock airbox well first there gonna see that it was taken apart (trust me you can tell, im a mechanic i can tell you whether or not a bolt was taken apart) and second of all im sure a stock RSX with a stock airbox wont suck up enough water to fuck up the o2 sensor, second of all when they take the sensor out they'll be able to tell.

Your best bet is to buy one used or a new one from oxygensensors.com and install it yourself, dont bother going to the dealership, getting pissed, and getting screwed
 

·
Registered
Joined
·
2,277 Posts
Sorry to revive an old thread, but I have a few questions regarding a similar situation. I too threw the P2A00 code after running through a deep puddle and having the hydrolock scare. The car runs fine, but my idle is all messed up and my CEL is on. Seeing that my mileage hasn't been affected, I wonder if my primary o2 needs to be replaced or not. I'm thinking my issue is the IACV, but I'm not entirely sure. Should I replace the primary o2 for peace of mind and just clean the IACV, or what do yall recommend? Thanks.
 

·
Registered
Joined
·
62 Posts
I had a hydro scare and was having the same issue, I replaced both the sensors on my exhaust and light is off and stayed off since three days ago.
 
1 - 14 of 14 Posts
Top