Acura RSX, ILX and Honda EP3 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good evening I have a 02 base rsx with auto transmission with 189000 on it I have a coolant leak that is driving me to drink car has a new radiator and hoses it looks like it is leaking from the upper hose on the motor put new hose clamps and put them on very tight. Drove the car for about ten mins and parked came out to a puddle of water under the car and a puddle sitting on top of the transmission. Please help before this car makes me a drunk
 

·
Registered
Joined
·
1,119 Posts
You're probably using the worm drive type of clamp. They aren't the best for many reasons, especially if you over tighten them. The better clamp to use is a spring type clamp, like what was on there from the factory.

Other than making sure the neck the hose is going onto is not deformed, clean and smooth, there isn't a whole lot else to check. Are you using the correct hose?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I am using a spring clamp the hose is new and the neck was cleaned and the sanded down any of the rough spots it is not leaking from the hose
 

·
Registered
Joined
·
1,414 Posts
In my experience, the spring clamps are what suck. You can try rotating it, but your best bet is to use another clamp. I ended up using worm gear clamps on mine, just made sure to use one that didn't have the slits all the way around so it didn't cut into the hose. Haven't leaked since. The other option is a T bolt clamp.
 

·
Registered
Joined
·
1,119 Posts
If its not leaking from the upper radiator hose to block joint, time to look elsewhere. There are coolant lines at the throttle body and possibly other lines in that area. I no longer have my RSX so I cant go look. You could wash down the area and let it dry. Go for a run and look for the source while slamming a beer. It sounds like a substantial leak if you are puddling on the ground and collecting on top of the trans.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
This is not my car. I found the leak which was a dry hard hose going from a nipple on the tube were the upper hose goes to a small nipple up by the air box. But when the kid was driving it to me to look at he pegged the needle all the way to hot. Now the car is blowing white smoke and running like trash with misfire on #3 all with flashing check engine light but no water in the oil I am saying a blown head gasket what's everyone think
 
1 - 6 of 6 Posts
Top