Acura RSX, ILX and Honda EP3 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
hi? i have a 2004 acura type s six speed. i need to change my engine ecu.

my ecu is not communicating to my OB2 and my car doesn't start but it cranks and all dash light turns on . no blown fuse

is there any problem using an ecu from a 2002 to 2004 on my car.
do i need to match the serial number?
do i need to flash it or reprogram the computer? before or after install? or no programing needed
will it be a direct exchange? plug and play

thank you
 

·
Vaginal Lubrication Tech
Joined
·
338 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #3
ok thank you. so i cannot just change the engine ecu without reprogramming. it looking like i am facing a big bill.

what could cause my obd2 that i have used on the car five day prior and now there is no connection between the ecu and obd2
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
anyone know someone or a company that can repair and fix ecu. please share contact information with me.
 

·
Always on TDY...
Joined
·
2,159 Posts
hi? i have a 2004 acura type s six speed. i need to change my engine ecu.

my ecu is not communicating to my OB2 and my car doesn't start but it cranks and all dash light turns on . no blown fuse

is there any problem using an ecu from a 2002 to 2004 on my car.
do i need to match the serial number?
do i need to flash it or reprogram the computer? before or after install? or no programing needed
will it be a direct exchange? plug and play

thank you
Are you sure it's your ECU? Start by checking your battery and starter. I think your starter is shot
 

·
Registered
Joined
·
27 Posts
Discussion Starter #7
the reason i am thinking is the ECU. everything was working except the rev or high idle problem. it all started when i connected the multimeter volt reading probe to the TPS plug.

everything was working, OBD2 connection to computer and gave me code p0122. car will start and driving.

ecu not connecting to obd2 and car not reving up when i depress the gas pedal in the RPM instead in decrease in rpm like it going to die but will not die or stall. all this started after i used the multimeter volt reading. when i hooked it up and i heard the noise shyy like spraying sound. i think my injection came on and pump gas and i started smell gas immediately. after this incident with the volt meter, i went back to start the car, it crank for a while before it finally start. it start running but when i press the gas pedal instead of the rpm and rev goes up it goes down and act like it will die but it doesn't when i let off on the gas pedal it will back to it idling rpm. the next day i went to start it again but no start just crank.


all dash lights are working, headlight works, engine icon on , green key flashing

is there a fuse for the TPS.

i put the multimeter volt red probe to TPS wire plug PIN A and the black wire to the battery negative terminal.

my concern is maybe with the multimeter voltage reading unit ( i bought this unit or multimeter from harbor freight . it is red in color) which i set at 20 volt may have sent power or volt through the TPS wire PIN A to the computer and harm it.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #9
update. i sprayed starter fluid in the intake and the car start. without the starter fluid car doesn't start. when car started and i push on the gas pedal the sound and rpm dropped and car acted to die. still euc is not communicating to the obd2. obd2 is working fine.

wow if i have to reprogram that will cost me more money. any other reasonable route to fix this problem
 

·
Registered
Joined
·
1,142 Posts
The fuel pump is what gets cut off. Kseries parts sells an immobilizer healer, but it may cost less to have it reprogrammed. You need to bring in the car to have it reprogrammed.
 

·
Vaginal Lubrication Tech
Joined
·
338 Posts
still euc is not communicating to the obd2. obd2 is working fine.
do you mean when you hook your scan tool to the OBD port, the scanner says it can't comm. with the ECU?

Have you opened up the ECU to see if any of the componets are fried?

I added a link to my signature with the 02-04 MFI wiring diagrams and also the ECU pinouts. I would suggest downloading it or the whole factory service manual
 
1 - 11 of 11 Posts
Top