Acura RSX, ILX and Honda EP3 Forum banner
1 - 16 of 16 Posts

·
Demonic
Joined
·
2,185 Posts
Discussion Starter · #1 ·
did the search on the engine check light and didn't find much other then the gas cap might be on tight or resetting the ecu...i tried it but it is the same problem and my car is still new been 6 months...anyway if i have a system hooked up in my car would the dealer blame it on that? Or the short shifter?...basically that is all i have and wondering if i should take out the short shifter...and hide the power wire for the system...thx all
 

·
Registered
Joined
·
2,672 Posts
an audio system and shifter have nothing to do with your engine. perhaps transmission or electrical. but i dont think those would be the reason so i would just take it to the dealer and see whats up
 

·
is Ultradian Bipolar
Joined
·
307 Posts
take it to an auto parts store like advanced auto. they will scan it for you for free and tell you why the code is comming up. why would you reset the ecu for the light? try using the odometer reset. it is in the manual on how to do it:thumbsup: if that dont work , and you cant figure it out, call the dealer. how many miles you got on it?
 

·
Demonic
Joined
·
2,185 Posts
Discussion Starter · #4 ·
i got the car in today...just waiting now...i have about 8500 ahah driven a lot the last 6 months...the odometer reset is for the service light not the engine check light....thx guys
 

·
Registered
Joined
·
61 Posts
Try the odometer reset anyway...it has reset my malfunction indicator light before...no shit....
 

·
Master baiter
Joined
·
11,278 Posts
the search button was my friend.
I didn't know about the odometer reset and used the search button.

this is just for the person that was fixing to ask about it.......
 

·
Car thieves shot on site.
Joined
·
164 Posts
My Malfunction Indicator Lamp went off the other day right after I bought my new '06 RSX-s. The guy I bought it from said that he filled the tank earlier that day and that he might not have screwed the cap back tight enough. I tightened the cap til it clicked and then let the car sit for an hour. The lamp went off and has been off for a few days now.

My only concern now is that I have had a recent malfunction code stored in the computer, and I have to go get an emissions test before I can register the car. Will this stored code fail my emissions test, and if so, what is the easiest / cheapest way to get it reset? I don't have a computer hookup, but if there are any other DIY methods, I might be able to tackle it myself.
 
G

·
My only concern now is that I have had a recent malfunction code stored in the computer, and I have to go get an emissions test before I can register the car. Will this stored code fail my emissions test, and if so, what is the easiest / cheapest way to get it reset? I don't have a computer hookup, but if there are any other DIY methods, I might be able to tackle it myself.
There will not be a problem. As long as you are not displaying a CEL during the inspection, there is no way for them to know that. Good luck.
 

·
Registered
Joined
·
694 Posts
Pull the ecu fuse for 10sec under the hood. open the fuse box and find the fuse for the ecu it should display the fuses on the cover and that should reset your ecu. or you can unhook you ecu and that will reset it too but the fuse is much easier.
 

·
Car thieves shot on site.
Joined
·
164 Posts
After pulling the fuse, will I have to drive it for a few days to let the car update its emission control codes before taking it to an inspection? How many days / miles does this usually take?
 

·
Car thieves shot on site.
Joined
·
164 Posts
Alright, I did over 50 miles last night, but the engine light still blinks 5 times before it goes off meaning the codes aren't reset yet. I need to get an emissions test so I can register the car. Will this fail my smog check if they haven't reset yet?
 

·
Car thieves shot on site.
Joined
·
164 Posts
Ok, so just in case anyone's curious I drove from LA tonight most of the way up the Pacific Coast Highway and back. It looks like the ECU logs the codes back into the computer at about 150 miles. So it's off to the emissions test and DMV tomorrow...god I hate the DMV.
 

·
Registered
Joined
·
1 Posts
engine light on could be a problem connect to the engline valve... i had dealer checked be4....replaced the valve, was under warranty
 
1 - 16 of 16 Posts
Top