Acura RSX, ILX and Honda EP3 Forum banner
1 - 11 of 11 Posts

·
Old Skool
Joined
·
1,345 Posts
Discussion Starter · #1 ·
I have search and found nothing.. my 02 type s w/ 97k miles appears to be having an oil leak from the oil presure switch. I noticed that there was oil leaking about 1 month ago. I cleaned the whole engine bay and sub frame of all old oil and grime. I just checked and it is still leaking I traced where the oil might be coming from and the oil presure switch has oil on it. I would like to know if anyone out there has this problem and if so how was this fixed? Also is this a common problem? Any info is appreciated. I have no warranty so I am not going to take it to the dealer.
 

·
Registered
Joined
·
885 Posts
i have an '02 with 109,000 miles... and guess what, i'm having the same leak from the Oil Pressure Switch. Hopefully the removal of the ops and hondabonding won't be too much of a problem... JSPEC, you get the leak fixed yet?
 

·
:)
Joined
·
15,563 Posts
oil p. switch from acura is around 7.00, just get a new one.
 
  • Like
Reactions: beach

·
Registered
Joined
·
579 Posts
Is the oil pressure switch area stock, or has it been modified for a gauge or other outlet? The stock threads are 1/4" BSP (british standard pipe thread - aka 'meteric pipe threads) Most common gauges and fittings over here are 1/4" NPT - national pipe thread. The two will fit together, but there is a slight difference in threads per inch, so a NPT fitting in the BSP hole can lead to leaks. A good dose of Hondabond or Permatex thread sealer should fix it, though. Just clean everything up good first and let the sealer dry before starting the car.
 

·
Shiny side up!
Joined
·
930 Posts
Oil pressure switch good.......oil pressure switch leaking oil bad ....get new switch !!! Don't play with it, seal it, or try to fit something aftermarket ....get a new one from acura ...put it in.
 

·
:)
Joined
·
15,563 Posts
$7.00 Ftw at Acura
 

·
Old Skool
Joined
·
1,345 Posts
Discussion Starter · #9 ·
i have an '02 with 109,000 miles... and guess what, i'm having the same leak from the Oil Pressure Switch. Hopefully the removal of the ops and hondabonding won't be too much of a problem... JSPEC, you get the leak fixed yet?

actually yes it did get fixed. I changed the vtec solenoid gasket/filter and removed the oil pressue switch and re-applied honda bond and it hasn't been leaking since it's been about 2 weeks now and it's still good.
 

·
Registered
Joined
·
885 Posts
actually yes it did get fixed. I changed the vtec solenoid gasket/filter and removed the oil pressue switch and re-applied honda bond and it hasn't been leaking since it's been about 2 weeks now and it's still good.
oh ok.. i think i might go w/ the new ops route. As for the VTEC Solenoid gasket/filter, does this HAVE to be replaced as well when you replace the ops?

Oh and one more question, when you had ure leak, did you have a popping sound whenever you turned your steering wheel while cruising at low speeds? I wonder if the two problems are related somehow... if not, then I think it might be my sway bar end link.

Thanks a lot guys for the help! :love:
 

·
Old Skool
Joined
·
1,345 Posts
Discussion Starter · #11 ·
I replaced the vtec solenoid gasket/filter since I wasn't sure if it leaked from there or the oil presure switch, but when I replaced the gasket/filter i realized it didn't leak from there replaced it anyways. Um no there was no steering noise. An oil leak will not cause a steering noise (popping soung)
 
1 - 11 of 11 Posts
Top