Acura RSX, ILX and Honda EP3 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Lately I’ve been dealing with bad compression in cylinder 1. It reads right below 120. But when I drive the car it skips/lags. I’m not sure if it’s a bad engine or I have some bad fuel injectors. My check engine is on and it misfires on every single cylinder. Also the O2 sensor is bad. I noticed that it wastes too much gas idling, I hear popping by the exhaust pipe and I don’t really drive the car in winter. Any suggestions as what it could be or should I just hand it over for someone to inspect? Thanks!
 

·
Registered
Joined
·
1,139 Posts
Why do you think the O2 is bad? It can be good, telling you that you have a problem--that's why it comes on, not only to get a new sensor. Go to Oreilly and for free you can get the codes and then start "thinking" what it might be. Low compression can cause those problems. How are the other cylinders?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Why do you think the O2 is bad? It can be good, telling you that you have a problem--that's why it comes on, not only to get a new sensor. Go to Oreilly and for free you can get the codes and then start "thinking" what it might be. Low compression can cause those problems. How are the other cylinders?
I actually did go to a local shop and it showed me misfiring on all cylinders and the O2 sensors being bad. Sorry should’ve clarified. Also the other cylinders are fine they work really well.
 

·
Registered
Joined
·
188 Posts
Trying to catch up? I had a similar problem and it was the "new" rebuilt injectors I got. Had miss in 2 cylinders, then it went to four? Dude gave me another set and all was well. It was then that I decided to do a better tune up other than that and the plugs. New O2's and CAT. Car ran great until I ran through a "puddle"....Now I'm rebuilding. Marco I'd like to send you some pix, P.M If you don't mind?
 
1 - 5 of 5 Posts
Top