Acura RSX, ILX and Honda EP3 Forum banner

1 - 20 of 77 Posts

·
Super Moderator
Joined
·
23,895 Posts
Discussion Starter · #1 ·
This morning my car tried to commit suicide and take me with her. Scariest thing I've ever seen. My electronic steering hasn't been working since I put her back together... last night I was trying to diagnose my radio issue and I realized I didn't have a fuse in for the cigarette lighter (which was also not working). Well my EPS on signal is connected to my cigarette lighter cause it's a constant 12v. So this morning when heading to work the worst scenario ever happened.


I was going down our second busiest main street and literally the steering wheel just started spinning uncontrollably, faster than you can imagine. It threw my hands right off the wheel and when I put them back on I still couldn't stop the steering wheel from spinning back and forth violently. The car literally flew across the road being whipped around like a match box toy. Finally as it started heading straight for the curb I pulled the key to turn off the power and was able to regain control of the car.

I turned her around but as soon as the EPS turns on, the steering wheel violently freaks out and becomes uncontrollable spinning in full 360 circles and going back and forth and shaking like crazy. I have no idea what to do but I know one thing for sure.. I'm pulling that fuse back out until I figure out an answer/solution.
 
G

·
Wow... crazy. Glad you were not hurt.

Wasn't there another guy with '05-'06 who had the same thing happen, but with the car on on jacks? I seem to recal that in the supercharger forum.
 

·
Curious Gooner
Joined
·
3,715 Posts
Oh man... thats crazy. Good thing you nor anyone else was injured.
 

·
OG Base Crew
Joined
·
4,118 Posts
Maybe the EPS was not Spaz approved. :confused:

Crazy though, lucky to be ok and I take it the car is too.
 
G

·
Part of me somewhat suspects that there is a fundamental incompatibility between the '05-'06 RSX and the EPS setup. Yes, obviously there is a signal speed difference that, on paper, we have been able to overcome but it seems like the only people who ever have issues on the EPS swap are the '05-'06 guys. No evidence, just a suspicion.
 

·
no longer moderate
Joined
·
5,145 Posts
WOW. Those EPS Racks are super easy to steer without the electric motor. I'd just stick with the power free rack, and call it a day.
 

·
Super Moderator
Joined
·
23,895 Posts
Discussion Starter · #10 ·
Wow... crazy. Glad you were not hurt.

Wasn't there another guy with '05-'06 who had the same thing happen, but with the car on on jacks? I seem to recal that in the supercharger forum.
Part of me somewhat suspects that there is a fundamental incompatibility between the '05-'06 RSX and the EPS setup. Yes, obviously there is a signal speed difference that, on paper, we have been able to overcome but it seems like the only people who ever have issues on the EPS swap are the '05-'06 guys. No evidence, just a suspicion.


It's mind boggling because it was working with minor faults two years ago when the car was still together. Only problem I had before was when you first turned on your car you would have no power steering, but once you hit 5mph it would turn on. Well today it tried to turn on but with extreme violence.


I wonder if the brain box has gone bad. The other thing I think I want to try is that dakota digital speedo converter.
 
G

·
You know, I have never had one issue with mine. Tha fact that yours had intermittent issues in the past I think is a significant clue. My gut reaction is that it's a electrical issue maybe on the supply or signal side, rather than an actual issue with the rack.

You know, K-Pro is SOOOO sensitive to bad grounding and and that sort of thing that it is possible that with all the work you guys have to do to get the ECU talking to the rack on your years, maybe even one little hiccup is all it takes to send things into a tailspin. This is all speculation, of course, just thinking out loud.

Shoot me a PM if you want to brainstorm this.
 

·
Super Moderator
Joined
·
10,732 Posts

·
just working for a living
Joined
·
634 Posts
man, so is it still safe to put one of these on my 04. was just about to purchase one next month.
 

·
bleep-bleep bleeeep
Joined
·
1,631 Posts
Radio interference immediately popped up in my head. Just throwing that out for brainstorming purposes. Maybe the fuse holder is acting like an antenna?

Glad you're okay, dude.

-scott
 

·
Super Moderator
Joined
·
23,895 Posts
Discussion Starter · #20 · (Edited)
Radio interference immediately popped up in my head. Just throwing that out for brainstorming purposes. Maybe the fuse holder is acting like an antenna?

Glad you're okay, dude.

-scott


My ground is actually behind the radio... and my brain box is under it... I am going to move the ground. For now I have pulled the fuse and test drove it with no problems... but damn:noes:
 
1 - 20 of 77 Posts
Top