Acura RSX, ILX and Honda EP3 Forum banner
1 - 13 of 13 Posts

·
Drinkin Haterade
Joined
·
5,394 Posts
Discussion Starter · #1 ·
So i installed an 02-04 primary o2 on my 05 so i can run k-pro. everything was cherry for a day until i tried running some datalogs and i was getting a primary o2 code. i cleared it a couple times thinking it might just be the car not liking the different o2 but then i started hearing a rattling sound coming from the area aroung my header and am now getting a "heated primary o2 code." i checked under the car and all the connectors are secure and both o2 sensors are definetely in all the way. Once i got the heated primary o2 code i stopped picking up a/f on my data display on my laptop. Did i fry my primary or what?
 

·
Former Mod-Still a God
Joined
·
209,105 Posts
for sure? is there something i can do to ensure this doesn't happen again? or does it just happen with time?
your primary o2 is deff friend i take it the code is 1167 or 1166? anyway yes its done get a new one, do you have a rh or stock cat? make sure the wires are not touching the subframe. the heater element in primary o2s are extremely sensitive be VERY careful when handling them do not hit them or drop them
 

·
Love ///My new car
Joined
·
2,725 Posts
primary is before the cat, secondary is for the cat so jsut the sensor is deff toasted
yeah my bad, speed reading missed the fact that he can't pick up a/f which isn't the secondary O2. i read the title and i know that i have the heater o2 turned off in kpro and thought it was the secondary. I'm in the wrong:eek:
 

·
Registered
Joined
·
12 Posts
i think im having the same type of problem. my k-pro keeps showing this code.

P1166 Heated Oxgen Sensor Sensor1 (Primary HO2S) Heater Circuit Malfunction

so i replaced the sensor, but still keeps showing up. you guys got any suggestions?
 

·
Whoop-d-doo
Joined
·
354 Posts
there's 1 way to check if the heater circuit is bad or not. if yall's got a multimeter, there's ganna b a conntinuity (sp?) if u look at the o2 sensor connecter, there's 4 pin's. if the heater circuit is bad, there shouldnt be any conntinuity on any of the combos. since there's 4 pins there's ganna b 16 combinations... (i hope yall know what im talking about) try every combinations, and if u DO get continuity, then ur heater circuit is OK, if u DONT get any continuity, then ur heater circuit is bad. thats how u check for heater circuit on pri o2 sensors
 

·
Whoop-d-doo
Joined
·
354 Posts
did yall reset the ECU after yall replace the o2 sensors?? if u dont have the scanner, disconnect the battery ground and put it back on again.
 

·
Whoop-d-doo
Joined
·
354 Posts
and if it gives the same code, heater circuit, now u know how to test the heater circuit, do the same thing, if no combo makes noise, then go get a new o2 sensor. time for exchange.
 

·
Registered
Joined
·
16,470 Posts
If you guys keep gtting codes back after you clear it, its toast.

1) poor gas mileag
2) unable to read a/f

are all signs its toast


Poor installation (i.e. vibrations, banging)
Running lean (High EGT's)

Will cause a sensor to fail.
 
1 - 13 of 13 Posts
Top