Acura RSX, ILX and Honda EP3 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
969 Posts
Discussion Starter · #1 ·
So i just swapped a K20 ITR complete swap and everything is running fine But my car wont engage in any gears i can let the clutch completely out while its in gear and it wont stall/grab any body have this problem or got a solution? ive tryed bleeding the clutch system a lil bit but im running out of ideas thanx
 

·
Breast inspector by appt.
Joined
·
9,245 Posts
There aren't a lot of options here, it's not the fluid, that only serves to disengage the clutch. First check the cables at the shifter and at the transmission. If that's okay, you aren't left with much besides incorrect clutch installation (something is holding it open) or a problem with the shift mechanism inside the tranny.
 

·
Registered
Joined
·
969 Posts
Discussion Starter · #3 · (Edited)
let me be a bit more specific the car can go in gear but when i let the clutch out including completely out it wont move forward or reverse what could be holding it clutch open? i have pedal and the clutch mechanism is moving i ordered the motor from h motors online and just installed it no weird noises but it wont go into any gear
 

·
Registered
Joined
·
579 Posts
Strange. I have heard of a few clutches getting stuck in the 'engaged' position, because that is the resting position. Really it's more like the pressure plate gets rusted to the flywheel. Sounds like you have just the opposite problem.

Was this engine / tranny already together when you bought it? Don't guess it's missing a pressure plate or has broken internals? Other than that rensoyka pretty much summed it up.
 

·
Registered
Joined
·
969 Posts
Discussion Starter · #5 ·
yea tranny and engine was together idk if its missing pressure plate or clutch cause i have installed the motor with tranny right in ya know?
 
1 - 8 of 8 Posts
Top