Acura RSX, ILX and Honda EP3 Forum banner

1 - 20 of 61 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
I have looked everywhere on this website to see how people have fixed their greddy kits on the type-s to make it work right. I have the knock sensor code and i know that other people have posted that they did too. But, they never said what the fix was. Was it not having the intercooler? The knock sensor adaptor box fouled? The e-manage?

I already had my e-manage swapped out and it wasn't that. I've also checked my wiring 5 times and soldered it as well. Please someone with the same problems help me. I am so frustrated with this kit and frustrated with Greddy for barely helping me. Thanks a lot.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #3 (Edited)
So, you had the knock sensor failure code? That is what I am getting. I believe it is code 23. But, what i don't get is that other people have the greddy kit without an intercooler and theirs is running just fine.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #4
Is there anyone that can please help me? Maybe throw in some suggestions that could possibly help.
 

·
Registered
Joined
·
1,313 Posts
Look man. Just call Greddy ( I know that it might be frustrating) and talk to KENJI. He will help you out.
Also, do not give up on your car. I almost ripped my greddy kit off my car and now i'm on love with it! it runs soo smooth and it kills lots of V8's!! lol
Just be patient and tackle your problem from the beggining... start with checking yoru knock sensor... the ignition coils and sparks... etc!! when it it throwing the code?? only when in Vtec?
 

·
Registered
Joined
·
198 Posts
Discussion Starter #7
It's throwing the Code 23 (knock sensor failure) right when i get on it at all even at low RPM's. It runs like crap even before the CEL comes on. Think that it is the knock sensor adaptor box even though i have check the wires and soldered them and also checked the voltage going in and out and they were the same? I'll try giving them a call. If you can find anything else out, let me know. Thanks.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #8
well...i talked to kenji today and i think that we figured out the problem. The knock sensor adaptor might be bad. Also, i'm only pushing 2 psi when i get on it. Pretty crappy huh? He told me that he had 2 customers that had clogged catalytic converters. I think that might be it because my exhaust got a lot quieter since I've had the kit on. But, he is going to send me a new knock sensor adaptor. Hopefully that does the trick.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #9
has anyone else had these 2 problems?
 

·
Registered
Joined
·
198 Posts
Discussion Starter #11
nope...tried the new knock sensor adaptor and it does the same exact thing. I read in another thread that this guy had the same exact problem and he replaced the knock sensor and it worked. So, gotta make some phone calls today trying to find one. So, this is the my last hope.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #12
GOOD NEWS!!! The CEL went away from getting a new knock sensor. The bad news is I'm only running 1lb of boost. I can't figure that out now.
 

·
K series tuning liberator
Joined
·
2,524 Posts
check the actuator rod.........to make adjustments to the rod counter clockwise lowers boost and clockwise raises it(i believe). This would be a last ditch attempt to solve the problem....make sure all the hoses are tight....check the intercooler for air leaks...and around all the fittings on all the compression pipes.....you could be leaking boost....i have had my compression pipe come completly off the throttle body....which caused a pressure drop in the manifold..that the boost gauge reads....showing less or no boost at all....the motor actually ran N/A with a turbo fuel map for about 5 mins until i could fix it. Which will cause it to run like total shit obviously (way too rich).
 

·
K series tuning liberator
Joined
·
2,524 Posts
Oh..and Tighten EVERYTHING!!!!!!
 

·
Registered
Joined
·
198 Posts
Discussion Starter #15
Well...whats weird is that in the past 2 months it went to 7 to 5 to 2 to 1 to 0 psi. My turbo is making a rattling noise when i rev it from the engine bay as the RPM's lower back down to idle. Wasn't there some kind of recall on the wastegate? I thought that i remember reading about that somewhere.
 

·
K series tuning liberator
Joined
·
2,524 Posts
could have the old actuator. Although that was taken care of awhile ago...you could have still gotten a kit that sat on the shelf a while.....

From what i understand, the bad actuator caused overboost problems. Still....check everything like i said....you never know.

The rattle could be coming from the actuator rod...... Nothing should be rattling up there around the turbo...

The rod could have loosened over time.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #17
problem fixed finally. The rod for the wastegate actuator was too lose. So, i tightened it back up and it is finally boosting again. The only problem now is that past 6k it feels like it is dying. Kenji told me that my catalytic converter might have gotten clogged from running rich for so long because of the CEL light. So, i'm getting a used one off of ebay and hopefully that will solve the problem. Also, what does it mean when the green light on the e-manage starts to blink orange for about 7 times then goes back to being green? I don't know what thats about.
 

·
K series tuning liberator
Joined
·
2,524 Posts
what exhaust do you have? Also...when the light goes orange....is that while driving..or at idle.....or with key on-engine off? what was the CEL light DTC(diagnostic Trouble Code), did you remember the code when it was cleared? Sorry for all the questions man....jus tryin' to help out. :)

Why not get a test pipe and free up that turbo....add some WHP.
 

·
You really paid for that?
Joined
·
2,045 Posts
I have a fix for all your greddy problems... throw it in the trash... lol just playing.

Good luck with everything. Why buy another cat, just get a test pipe...or do you have emissions... got love florida (we are slowly killing ourselves)
 
1 - 20 of 61 Posts
Top