Acura RSX, ILX and Honda EP3 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I ordered these parts last week and I’m trying to make sure I have everything covered so I can just do it when they arrive...

I’m a little confused about all of this, i purchased skunk 2 pro series intake manifold and skunk 2 pro series 70Mm throttle body. So here it goes. On the top the the throttle body there are two sensors, one with a air hose. On the S2 TB there is only a hole for the one sensor. So wth do I do with the other one?? What do I do with the air hose that is attached to that sensor??

I read on kseriesparts website someone said not to attach one of the small coolant hoses or it will just shoot Coolant into the intake manifold.... what’s up with that.. details please....

Lastly.... the picture of the s2 intake manifold shows that the waterneck and the manifold are all one piece. So where in the hell do I purchase the waterneck attachment that screws in???

please include all details that you can think of and anything that i really should know before attempting this. Thankyou all for your help.
565725
 

·
Registered
Joined
·
1 Posts
Map sensor on the left, evap purge sensor on the right.

The only sensor you need is the map sensor, evap can be left off the tb and switched off with kpro.
If you don't have kpro leave sensor plugged in to harness but disconnected from throttle body.

Should be all good

Sent from my CLT-L09 using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I do not currently have kpro. I will be getting it but for now, I haven’t installed the pro manifold or throttle body. U think it would run ok until I get kpro if I installed it? I’ve been told by someone else possible limp mode is why I haven’t.
 

·
Registered
Joined
·
1,143 Posts
I do not currently have kpro. I will be getting it but for now, I haven’t installed the pro manifold or throttle body. U think it would run ok until I get kpro if I installed it? I’ve been told by someone else possible limp mode is why I haven’t.
Limp mode or not, you will more than likely be running lean and the car will be slower. It is not recommended to run anything more than bolt ons on a stock ECU, sometimes even that will make you run lean.
 
1 - 4 of 4 Posts
Top