Acura RSX, ILX and Honda EP3 Forum banner
1 - 14 of 14 Posts

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #1 ·
Ok I attempted to clean the IAC Valve when Installing the RBC. I put it back turned on the car no check engine idle lies around 1200-900 rpms....after some stop n go driving the light comes on....Is it broke or did I just do a shitty job cleaning? I'm gonna go for a second cleaning right now hopefully that works....
 

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #3 ·
ticklemedaly said:
check what the code is. you probably just tripped a fuel trim code.
Trouble Shooting P0505
The PCM has determined that a malfunction exists in the idle control system

Are you saying I'm just running lean? if so K-pro is the only fix right?
 

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #4 ·
well i just sprayed TB cleaner in the TB wiped it down reset the ecu and my car has been idling for about a half hour no engine light yet...hopefully that fixed it, still idling as we speak
 

· 12 ASE Certs and counting
Joined
·
632 Posts
well, looks like you probably had the key on or something stupid when you disconnected the IAC. Now, did this code exist before hand or afterwords? As is this the code that made you clean the IAC to begin with?
 

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #6 ·
ticklemedaly said:
well, looks like you probably had the key on or something stupid when you disconnected the IAC. Now, did this code exist before hand or afterwords? As is this the code that made you clean the IAC to begin with?
there was no code I installed RBC and I thought the idle and the opening and closing of the TB was funny so I thought it needed to get cleaned, cleaned.... I'm pretty sure I had the battery disconnected through out the entire ordeal. The funny thing is I idled the car for about an Hour, no code. Went drove around park up in my drive way...code... :dontknow:
 

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #10 ·
did a new IAC valve fix your problem? i had a surging idle....cleaned my iac now my idle wont drop below 1800rps. i got the p0505 code too.
well my idle would settle around 1000-1200 rpms, and no It didn't fix it...i ended up having to get a new TB because a sensor on the TB was broke.
 

· Breast inspector by appt.
Joined
·
7,717 Posts
Considering the sensors that are in the intake system, I certainly wouldn't try to clean an IAC valve by just spraying cleaner into the intake. You should take it apart properly, clean it and dry it, then put it back together again.
 

· Mangekyou Sharingan!
Joined
·
1,808 Posts
Discussion Starter · #13 ·
it was a lesson for me sometimes its cheaper to pay someone to do it...instead of DIY especially when its your first time
 

· Registered
Joined
·
2 Posts
I been having an issue where my idle surges, I get the check engine for malfunction IACV. This was after I installed the ultra street manifold and the throttle body pro 70mm (skunk2). I cleaned the Ivac, everything is hooked up correctly, I can’t seem to find a solution to fixing it. I got a IACV delete kit but I don’t wanna resort to it but it might have to be my last choice.
 
1 - 14 of 14 Posts
Top