Acura RSX, ILX and Honda EP3 Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
631 Posts
Discussion Starter · #1 ·
so i put in my innovative street mounts kit and after that it feels like my car runs horribly... when i give it just the right amount of throttle it lugs really badly...now i'm not sure if my car was already having this lugging problem and i never noticed it and then when i got the mounts it made it so when ever my engine lugs it makes my whole car lug but it's bad....if i'm in first gear (the most sensetive gear to the throttle) with my foot totally off the cluth and just SLIGHTLY accelerate, my car will lug...it doesn't matter what rpm or what gear, but if i give it just the tiniest amount of gas, it lugs horribly...and it doesn't make sense to me that the mounts would have caused this but only would have made the lugging more obvious. however, if i give it a bit more gas, the car runs fine...so i find myself having to drive like an idiot in a constant hurry just so my car doesn't lug...or if i give it just under the amount of throttle to avoid the lugging...well...it's a honda so that's a little too slow. now just so you guys understand what i mean by lugging, i mean that my whole car will jerk horribly. picture your car in first gear with the clutch totally out and keep tapping the throttle...that's what it's like and in the higher gears (being a little less sensetive to the throttle) i don't really feel a lug but i can hear it...and actually i can feel it a bit in the throttle... i already searched and couldn't find any answers...all i can think of doing at this point is putting my stock mounts back in...which is a bitch..and i don't see why i should have to do that when it seems like no one else has had similar problems with their mounts. any input would be appreciated. oh! and also my fourth gear (and usually only my fourth gear) has become really knotchy to get into gear almost as though it's one click and then an additional effort to push it all the way into gear. i blame the clutch and not the tranny but who knows.
 

·
Banned
Joined
·
3,064 Posts
thats common in any manual car. by freinds evo does that, because you keep puting your foot on the throttle tapping it constantly. its not a problem, thats how it is.
 

·
Member
Joined
·
7,611 Posts
This is one of my biggest gripes about this car. PITA to avoid jerky when crawling around parking lots, etc.

Your motor mounts just made it more noticeable, they didn't cause the issue.
 

·
Registered
Joined
·
2,364 Posts
This is one of my biggest gripes about this car. PITA to avoid jerky when crawling around parking lots, etc.

Your motor mounts just made it more noticeable, they didn't cause the issue.
:iamwiths:

I noticed the same thing when I put the inserts & td in my car also.. just takes some getting used to
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #5 ·
PITA?? And it even does it at higher speeds. I can be in sixth and if I give it just the right amount of throttle it will vibrate horribly...so you guys say that's normal??? And I was using the "tapping" as an example. When I give it the right amount of throttle in a lower gear ( a continuous amount) it jerks AS THOUGH you were tapping the throttle
 

·
Member
Joined
·
7,611 Posts
PITA = Pain In The Ass.

Hmm, no, I don't notice it in higher gears, except a little bit sometimes in 2nd.

It's normal in lower gears, it's a very sensitive throttle.

If it vibrates 'horribly' in higher gears, maybe you should recheck your MM bolts, make sure they're all torqued properly.

Do you get rattling noises too? Loose bolts will usually make noise too.
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #7 ·
Yeah, it rattles but I was told that was normal. It just lugs feels like the throttle is being tapped when a certain amount of throttle is applied. Remember...the throttle is not actually being tapped!!
 

·
Registered
Joined
·
1,251 Posts
PITA?? And it even does it at higher speeds. I can be in sixth and if I give it just the right amount of throttle it will vibrate horribly...so you guys say that's normal??? And I was using the "tapping" as an example. When I give it the right amount of throttle in a lower gear ( a continuous amount) it jerks AS THOUGH you were tapping the throttle
Hey you problem sounds just like mine. I have had innovatives for a while now and never had a problem but I just did my clutch and had to take 3 of the mounts off and I have the exact same problem as you now. It almost feels as if the car is struggling sometimes it sucks.
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #9 ·
Hey you problem sounds just like mine. I have had innovatives for a while now and never had a problem but I just did my clutch and had to take 3 of the mounts off and I have the exact same problem as you now. It almost feels as if the car is struggling sometimes it sucks.
Hmm...if you're planning on having your problem looked into then keep me updated...if I had to put money on it, I would almost say that something was wrong with the throttle or fuel system since it only does it when a certain amount of throttle is given...that or an exhaust leak...which would explain the problem when in higher gears.
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #10 ·
bump for more input???
 

·
I can drive up your rsx
Joined
·
29,087 Posts
Search for grounding points and innovative mounts. Could be your issue.
 

·
Member
Joined
·
7,611 Posts
??

If drumnatural is referring to the ground that attaches to the passenger side OEM mount and has to be relocated when using Innovative mounts, the car won't even start unless that ground is grounded.........
 

·
Registered
Joined
·
631 Posts
Discussion Starter · #14 ·
...bump...
 

·
'Ello Dutchie
Joined
·
1,757 Posts
Hmm with my new mounts I kinda get what you are talking about only in first gear, in my opinion I think you just need to get used to it.
I'm not able to drive exactly in the same way I drove with stock mounts example, slowing down, beginning to accelerate, shifting, they all feel pretty different, this could be your problem and maybe you are just thinking about it too much.
 

·
Registered
Joined
·
856 Posts
??

If drumnatural is referring to the ground that attaches to the passenger side OEM mount and has to be relocated when using Innovative mounts, the car won't even start unless that ground is grounded.........
I'm pretty sure that ground is off on my car, there is a broken braided strap on the passenger side. Where is it supposed to attach to the engine?
 

·
Registered
Joined
·
150 Posts
I have stock mounts and I can feel the lugging. Or more violent jerkiness at low speeds.

Especially happens at speeds lower than 20 in 1st or 2nd.
I can also see the rpm's jumping around.

You guys have these same problems too?
 

·
Banned
Joined
·
3,064 Posts
I have stock mounts and I can feel the lugging. Or more violent jerkiness at low speeds.

Especially happens at speeds lower than 20 in 1st or 2nd.
I can also see the rpm's jumping around.

You guys have these same problems too?
any manual car has that. its only a problem if its an automatic doing that.
 

·
Banned
Joined
·
3,064 Posts
Does it get worse with time?
It seems like the jerkiness has gotten much worse in the last month.
Especially in 2nd.
it depends. if you are driveing around in 2nd, keep your foot slightly on the gas, and hold it. if you let go, thats when it gets crazy. same goes for first, and sometimes 3rd. if you find its still jerking too much, just clutch in and let it roll a lil bit.
 
1 - 20 of 23 Posts
Top