Acura RSX, ILX and Honda EP3 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I'm new here but have been searching the forums for the past few months trying to find answers. So far I've found a bunch of things that could cause 1 problem but not the other. So I'm tired of scratching my head testing stuff to get no result, so here I am making a post.

Last year someone tried to steal my rsx which lead to my factory key no longer working. I ordered a new ignition lock cylinder from Honda had it installed and the new key programmed to it. Since then I've been noticing more and more stuff going on with the car. I've talked to Honda they say it's the immobilizer but when checked it is still working and installing a new one and getting it programmed didn't fix any of the problems either. All the problems are listed below.

1. Auto windows don't work (rolling up or down)
2. Key Fob will not program back to car
3. Radio has no power unless I jump the memory wire to a fuse
4. Gauges jump all around when first starting the car
5. After about 10 mins of driving the car it kicks into limp mode and won't go over 3k rpm
6. OBD Port has no power
7. Interior lights will not come on with doors opening
8. Door locks don't lock or unlock the doors unless car is started (even then will only lock and unlock the hatch)
9. Service Engine soon light will not go off (I can reset it and as soon as I turn the car off it comes right back)

I'm driving the car more now trying to find all the things going on and finding more every day, car is a 02 RSX Base
I've changed every fuse and relay in the car, tried other ecu, changed door lock actuators, changed fuse box under hood and under dash, new OEM vtec solenoid, new oil pressure sensor, tons of stuff has been thrown at this car trying to figure out what is going on with it. I'm just at the point of either it needs to get fixed or I need to admit it's dead and send it to the scrap yard and put the swap in something else
 

·
Super Moderator
Joined
·
444 Posts
I've talked to Honda they say it's the immobilizer
I would start there.

Also in order to work on certain parts of the car other parts of the car have to accessed. Where there has been human play or work there typically is an error of something simple. A ground not re-installed, connector, another damaged part that occured at the same time as something completely random. Electrical seems to be the problem you are smelling..

Have you tried going through the Honda RSX service manual? That is what Honda will do in the troubleshooting section first thing.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I would start there.

Also in order to work on certain parts of the car other parts of the car have to accessed. Where there has been human play or work there typically is an error of something simple. A ground not re-installed, connector, another damaged part that occured at the same time as something completely random. Electrical seems to be the problem you are smelling..

Have you tried going through the Honda RSX service manual? That is what Honda will do in the troubleshooting section first thing.
That's what I was saying is they said it's the immobilizer but we have bought a new one and installed it and it didn't fix the problem. They just keep going back to it's the immobilizer not taking the program like it should. But can't give me any answers as to why it's not
 

·
Super Moderator
Joined
·
444 Posts
Open & Shorts

Open - a break in electrical wire or at a connection

Shorts - an accidental connection of a wire to a ground or another wire.

Something in that harness is damaged possibly, meaning the wire is broken (open) and/ or there maybe an accidental connection to a ground or another wire. I am willing to bet it has something to do with human error. However with complex electronics with our systems (such as ECM's & PCM's) something can still work not just the way it should or it will not work at all.
 
1 - 4 of 4 Posts
Top