Acura RSX, ILX and Honda EP3 Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
I just bought a 2003 RSX at an auction and while driving it home I noticed the speedometer and odometer are not working. I don't know if somebody has intentionally done this or not, I just need to find out how to resolve this problem. I am not an RSX buff like most of you here so any info might be helpful. Where do I look, could something be unplugged, if so, where? The RPM guage works if thats any help. Thanks again.

By the way, is it hard to take out the head to check and see if it is unplugged?
 

·
likes to troubleshoot
Joined
·
2,539 Posts
Check your fuses first. Do a search, also, for the specific fuses. This has been discussed before.
 

·
no mo my rsx type S
Joined
·
1,101 Posts
hey with your odometer out you actually save on milage.:) lol
 

·
Registered
Joined
·
5,755 Posts
test it out now and when the cop pulls you over tell him its not your fault, you can't tell speed
 

·
!!!Master Member!!!
Joined
·
5,969 Posts
where are you located at? I have something that you can check out but i cant expline it there. There is a wire that you need to check assuming someone did this intentionally. This wire is located in the inside of your car. have you taken a look at your FUEL INDICATOR. the wire that i'm talking about, if it is disconnected then when you are driving your fuel gauge will also flactute alot. Like if you make a sharp turn you will see it fall down and go back up. If you are local i can come check it out for you.
 

·
Registered
Joined
·
1,582 Posts
I would say that you just either bought a wrecked car or a car without the true odometer reading on it because it has been tampered with.
 

·
Breast inspector by appt.
Joined
·
9,226 Posts
Fuse #10 under the dash (far right fuse on the bottom row) runs the gauges.
 

·
WW
Joined
·
161 Posts
My friends BMW has the same problem. I guess BMW told him the sensor had gone out and needed to be replaced. I don't know if it works the same with the RSX though being a whole different car maker.
 

·
Registered
Joined
·
5 Posts
No SiK,

The Speedo and Odo are not working. All fuses are fine even under the hood and no lights or codes.
The Acura dealer can read the speed from the DTC. The VSS sensors are good, and i changed my cluster out and i get the same prob.
My car is an '03 Rsx base model... auctioned car(tamper with).

The Blue/Wht wire is reading the same volts to the back of the cluster as it reads from the ecu.

my cruise control is out too....

i saw your reply to golik and it seem it might be as you say?
 

·
Registered
Joined
·
9 Posts
hey i have a problem with my gauges. i went in and tried fixing my fuel gauge and i messed all my gauges up and got a speeding ticket because i didnt know how fast i was going, but thats besides the point. does anyone know where i can find replacement OE gauge pods all i want is to have my normal gauges with temp. rpms. speed and gas level please help!!!
 

·
!!!Master Member!!!
Joined
·
5,969 Posts
No SiK,

The Speedo and Odo are not working. All fuses are fine even under the hood and no lights or codes.
The Acura dealer can read the speed from the DTC. The VSS sensors are good, and i changed my cluster out and i get the same prob.
My car is an '03 Rsx base model... auctioned car(tamper with).

The Blue/Wht wire is reading the same volts to the back of the cluster as it reads from the ecu.

my cruise control is out too....

i saw your reply to golik and it seem it might be as you say?
I am

I am going to need to check my car to figure out what wire I am talking about. Its been so freakin long since I looked at the RSX electrical manual.
 

·
Goddamn Im in tha sky!!!
Joined
·
104 Posts

·
Registered
Joined
·
5 Posts
Thanks SiK,

i know, its been almost 3 years, ha.

but anything will help. i have been fighting this thing for a year. thanks

and dankeezie, i got a extra cluster, AT and 8900k miles on it.
 
1 - 20 of 28 Posts
Top