Acura RSX, ILX and Honda EP3 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
Ok so a couple days ago I swapped out my CAI filter for a new one and when I was bolting my bumper back on from under the car I saw oil dripping from my car. I'm pretty sure it's the engine oil because my oil levels have been dropping since I did my oil change about 4 months ago. I just replaced my transmission oil and don't think it's that what's dripping. Once I wiped the oil drip from the location on the pics I didn't see it drip for about a minute.

View attachment 497513
View attachment 497521
View attachment 497529


Where the oil was dripping from it looks like it wasn't flush with the rest of the transmission. I had my transmission fluid changed at a Honda Dealer. I assume it's my engine oil because my engine oil level is low, but it looks like it;s dripping form the transmission. Is there any way I can stop this? I saw some liquids they say stops oil leaks that you put in your engine? I'm just not sure what it could be. Is their a way to rub some product on the outside where I found the leak and just stop it that way? I really don't know what to do?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #2
Sorry about the double post, the first one had the wrong pics. These are more informative and I don't know how to delete the first post.
 

·
Registered
Joined
·
5,790 Posts
DO NOT use those stop leak products. They causes more problems later on.
The oil could either be rear main seal on the engine or the input shaft seal on the transmission.

Engine oil level going low could be many other reasons. If you are not loosing too much oil, it may not be worth it to fix. How long does it take for the oil to go from the top dot to the bottom dot on the dip stick?
 

·
bleep-bleep bleeeep
Joined
·
1,631 Posts
If you did your oil change 4 months ago, and it's been leaking or low ever since; I'd check the oil filter and drain plug.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
The drain plug is fine. When I check it its like its not flush together where the bolt is. Like a small gap maybe
 
1 - 8 of 8 Posts
Top