Acura RSX, ILX and Honda EP3 Forum banner

21 - 40 of 59 Posts

·
Speedy
Joined
·
2,648 Posts
update - dropped in at my local advanced auto to read the codes (cool setup, they let connect the obdii code scanner to the car yourself and you take the code reader back in the store. then they connect to a printer and print the codes for you - sweet service)

anyway - i got the P0845 (3rd clutch pressure switch). i got lucky it's an external threaded body switch - like changing a spark plug. but it's under the airbox/battery.

and bemb is right it's tight and not much room, book calls for removing the air-box, but other than that it's a cake walk..

i reset the ecu to see if goes away and checked the fluid level, i may change the fluid as well before doing the sensor....
 

·
Speedy
Joined
·
2,648 Posts
Enyce21 said:
damn, had this also happen to my 03 auto with 30k miles...took it in to acura and had them change the tranny fluid, but they couldnt find anything wrong with the tranny itself. a day later it started flashing again :firemad: . but since then it has completely disappeared :confused:. hope it doesnt come back...

and like the above poster, my car has been babied as well. WTF.
if it comes back, go to the auto part store to read the codes so you know wtf is going on -

or if you go back to the dealership ask for the error code and we'll look it up for you or you can download the pdf manual that's floating around here.
 

·
Speedy
Joined
·
2,648 Posts
pos auto - funny thing is, i drive my mod'ed S like it's stolen daily. I've even have the red-line set to 8800 rpm via kpro. i bounce the tach's needle off the red-line all the time and the S odometer just turned 99,958 miles. i drive so bad the wife won't let me drive her pos. maybe that the problem i need to drive hers and blow the shit out...

the only wrench thats been laid to my S is for oil, oil/air filter changes, tranny fluid changes, and one set of plugs - none of the other bs maintanence that the book calls for....

my wife's car still smells new, my car smells like oil can/fart (well not really that bad but the new smell is long gone)
 

·
Speedy
Joined
·
2,648 Posts
no - i just read the codes last night and have not changed the atf or anything except reset the ecu, thinking about doing the atf this morning. i checked the level and it's a full reading on the stick...
 

·
Registered
Joined
·
22 Posts
Hey all, sorry for bringing this topic up again, but my RSX 02 came up with the P0845 code. Can someone give me the part # to order from Acura ? Thanks.

Jack
 

·
Registered
Joined
·
22 Posts
bump. Please help. My car's 3rd gear seems to stay there , d oesn't want to switch. I should change asap. Anyway know the part # of the 3rd clutch switch ? I can't find it anywhere on the web or acuara parts online.
 

·
Breast inspector by appt.
Joined
·
9,226 Posts
Just call the dealer and ask for the "3rd clutch transmission fluid pressure switch".
 

·
Registered
Joined
·
22 Posts
rensoyka said:
They're dopes there. They could at least look at a diagram of the tranny and figure out what you want. Try asking for an oil pressure switch. Try this link:

http://www.acuraoemparts.com/delray/jsp/prddisplay.jsp?inputstate=5&catcgry1=RSX&catcgry2=2002&catcgry3=3DR+RSX&catcgry4=KA5AT&catcgry5=SOLENOID&ListAll=All&vinsrch=no
Thanks buddy for helping me out. So I should order this part? :
010 28600-PRP-003 SWITCH, OIL PRESSURE . Its about $30.12 USD. Is that the same part ( different name ?) 3rd clutch switch ? Thanks.

jack
 

·
Breast inspector by appt.
Joined
·
9,226 Posts
I'd still take the info to the dealer, best if you actually go there instead of just calling, and make sure it's the right part. You really should take the old one with you if possible to get an exact match. Most places won't let you return anything electrical if it's the wrong part. Then if it's too expensive there, you can order on the internet with confidence that you have the right one.
 

·
Registered
Joined
·
22 Posts
Update for anyone who might have the problem in the future. Part # is 28600-PRP-003, ( aka oil switch ) verified by local acura dealer. Paid $40 for it, coming tomorrow. To download the repair manual for our RSX, email me or IM me.
 

·
OG Member
Joined
·
21,422 Posts
anyone have DIY for this?

looks like an easy part to replace but anyone have actual pictures where this oil pressure switch is on the tranny (its not near the oil filter as stated in the helm's manual)
 

·
Registered
Joined
·
169 Posts
Yeah I have an 02 Auto and just started getting the same thing. I dont notice anything different when im driving.. Just the light flashing.. Not all the time only happens every once in a while. imma go get the code read and go from there... thanks for all the replys about this.. i was scared there for a min.
 

·
AdDiCtED~2~SpEeD
Joined
·
51 Posts
ya wen my car was automatic, i had it in ss all the time and would redline that shit all the time racing and just bull shitting until the check trans light came on (Flashing "D")and my trans was basically screwed thats one of the reasons i got a auto to manual swap. So ya watch how you use it cause u can fuck your trans up.
 

·
Registered
Joined
·
169 Posts
ok so i left it go for a little cause it went away. It started to come back again.. I got the code read and it was the P0845 "trans fluid press sensor/ switch B circuit malfunction. SO is the "3rd clutch transmission fluid pressure switch" the same thing as P0845? I have 2 frinds of mine that are Mechanics so im going to be doin it myself just want to make sure i getthe right part.

PS by the way.. i love this car forum. Every issue ive had whitch hasnt really been much ive been able to fix by checking out clubrsx. thanks for everyones help.
 

·
Registered
Joined
·
297 Posts
hey guys. im having some problems with my transmission after hitting a big bump since my car is low. i got my car checked with the scanner and the code came up to "P0708 Shift Solenoid Malfunction." I brought it to a shop and they said that it might be the transmission fluid so I got it flushed since it was dirty anyways. but there was no luck even after I did that. My car is an base auto 2003. When I drive my car in automatic mode it would drive fine but would not go into 5th gear at all and sometimes when I drive it in automatic mode it would randomly slip into neutral but it would still be in "D" then I would have to put it in neutral let go of the gas a little bit and it would go back into gear again. My "D" light also blinks and I tried resetting the ecu by disconnecting the battery. It would work for about 5-10 minutes driving fine then after the CEL would come on again and the "D" would start blinking again. Sometimes I can't even put it in SS mode. So i'm guessing one of my solenoids are bad but I dont know how to check which one. any help? thanks.
 

·
Breast inspector by appt.
Joined
·
9,226 Posts
that code doesn't show in the manual, but if your problem is the transmission range switch, the part is about 40-50 bucks. see the manual for replacement procedures
 
21 - 40 of 59 Posts
Top