Acura RSX, ILX and Honda EP3 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
I have this intermittent squeaking noise that is around the passenger side quarter panel area, possibly suspension area. This was a pre-existing noise I had when I purchased the vehicle 3 months ago. I had my vehicle checked out by my mechanic and it needed new rear struts and sway bar links and wheel bearing, so I got them all replaced and the vehicle rides a lot better. However, that irritable intermittent squeaking noise still remains. I checked the back seat, the poly-styrene spare wheel cover and the interior trunk moldings etc, and those don't seem to be the problem. I went to a lube facility and there is nothing they can do. The oil/lube shop suggested that it may be a lose nut/bolt somewhere underneath the trunk interior felt coverings. Just not quite sure what it could be so thought I would come here to see if any of you folks have experienced this, and if so, what it might be and if there are any possible solutions.

And yes, I did do a search for this prior to posting this inquiry, so as to not get flamed as a newb :) I couldn't locate any such similar posts.

But, if any of you have any helpful suggestions, I would be certainly grateful.

Thank you.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #3 ·
Thanks, I went ahead and checked that out too, but it was not the culprit :(

Took vehicle back to the shop and found out that it is in fact the Right Rear Strut, fluid is completely gone. Shop guy forgot to tell me that he had to order the struts from dealer, which evidently were out of stock, and then have me bring back the car to have them installed. The guy felt so bad about it said that he will not charge me for the install since I was never charged for them anyways, but will still need to pay for the part.

Thanks again for all your help.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #5 ·
Well, had the Struts replaced. Not cheap either, they are different than the base RSX ones (KYB?) I was originally quoted. Found out the OEM are (Koni).

Anyways, drove off the shop lot and in about 30 seconds, that damn right rear suspension area started squeeking like a a biatch again. OMG, it is so annoying. It is still intermittent though. Sometimes it will squeak for a few minutes and then just go away, other days it don't squeak. I am still at a loss as to what it could be.

On another note. Now that I got my car back, I noticed that the right side of my car is just a bit higher than the left side. Granted, I Just had Eibach's springs put in for a 1.5 inch drop, and when I first got it back after installing the springs, the left side was higher than the right side, then both sides appeared to settle to the correct and equal height. But, after getting the car back after the Struts were installed last week, the opposite has occurred, the right side is higher than the left? weird?? Mechanic told me to drive it around a few more days to see if the suspension settles a bit more, and if not, then to bring it in for adjustment. Is this normal? or were they just not adjusted and/or installed properly?
 
1 - 5 of 5 Posts
Top