Acura RSX, ILX and Honda EP3 Forum banner
1 - 20 of 24 Posts

·
G - Monay
Joined
·
4,209 Posts
hmmmmmm i had this problem before... hazard works but then turn signals didnt.. i checked all fuses and none blown... and i start messing with the hazard button. like keep pressing on it then it start working again....... weird
 

·
Registered
Joined
·
176,695 Posts
yea its not the fuses, cuz if it was the fuse ur city/parking lights will be off too

i have the same problem u do except my hazards dont work but my signals do...i'm trying to figure that out aswell...i'm thinking a bad connection somewhere. i also did a 05/06 front end conversion
 

·
likes to troubleshoot
Joined
·
2,539 Posts
The turn signal and flashers work off different fuses. Under-dash fuse #19 feeds the flasher when the turn signals operate. Under-hood fuse #5 feeds the flasher when the flasher operates.
 

·
Banned
Joined
·
54 Posts
check fuses and bulbs.if okay then try messing with the hazard swith. could of gotten stuck a little and that does cause the signals not to work in some vehicles. other wise you proably will need a new switch
 

·
X-Box Tag: bjsecoy
Joined
·
1,244 Posts
I have the same problem. I have checked all fuses, none are blow. I replaced them anyways, still not working right. Now I am on my third hazard switch, and my problem went from turn signals working and hazards not working to hazards working and turn signals not working. My head hurts from troubleshooting it. Does anyone have a schematic of the hazard swithch? If so, I will just wire up my own.

FYI: I am an electrical engineer and know what I'm doing here, so please don't suggest fuses again.
 

·
likes to troubleshoot
Joined
·
2,539 Posts
No schematic of the actual flasher relay, but the schematic for the flasher/turn signal circuits are in the Helm on pg 22-88.
 

·
Registered
Joined
·
202 Posts
can anyone help me out with this? i have a similar problem, but both the hazards and the turn signal doesnt work. i've checked the fuses, they werent blown, but i replaced them anyway...still nothing :(
 
1 - 20 of 24 Posts
Top