Acura RSX, ILX and Honda EP3 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Guy's

Need some help. Bought a turbo'ed 06 RSX Type S that had a ringland failure. I swapped the motor and fixed up the shoddy nonsense the last guys had done. The car is running good now, but I don't have a reading from the speedo.

The car has a legit Hondata Kpro and jumper harness installed. The config is good in the tune and the data log and OBDII show accurate speeds, but no speedo at the cluster. All the other gauges are working fine though.

Looking for ideas or the help of someone familiar with the pinouts and signal types for this setup. FYI, the speedo was not working when I bought the car either, but I have tested with the factory ECU and it did work.

Thanks in advance!
dp
 

·
Mental Midget Fighter
Joined
·
357 Posts
What is the serial number of the K-Pro board inside the ECU, and what is the serial number on the outside of the ECU case?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
The kpro serial number is 05004189, ecu part number is 37820-prb-a04 with the serial being 2068-300338 0G11 I think. Also, fuel gauge is very slow to respond when filling up. Cruise control not working either.
 

·
Mental Midget Fighter
Joined
·
357 Posts
There is no record of this ECU being modified for an 05-06 RSX and that is why it is probably not working for you.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
That's funny because it has the hondata black sticker stating that it has been. It also has the hondata jumper harness with the gray plug. Perhaps there is a mistake in your records, or someone went through great lengths to counterfeit a sticker to affix to a hondata kpro conversion that you do apparently have on record?

Help me understand this please, need a speedo and odometer.
 

·
:)
Joined
·
15,545 Posts
is the speed reading in the ecu? Do a datalog and find out.
Is your countershaft speed sensor enabled in parameters?
 

·
JoE
Joined
·
1,617 Posts
I had simialr problems when I was on cruise, the speedo would blip then cruise would shut off. It did that speratically, hope you find a cure.
 

·
Registered
Joined
·
59 Posts
I had simialr problems when I was on cruise, the speedo would blip then cruise would shut off. It did that speratically, hope you find a cure.


@06_typeS What did you do to fix that quick shift mine does it never really has bothered me, but if its an easy fix i'd love to fix it.
 

·
JoE
Joined
·
1,617 Posts
My solution was that I sold the car and bought an NSX lol.
 

·
Premium Member
Joined
·
15,843 Posts
That's funny because it has the hondata black sticker stating that it has been. It also has the hondata jumper harness with the gray plug. Perhaps there is a mistake in your records, or someone went through great lengths to counterfeit a sticker to affix to a hondata kpro conversion that you do apparently have on record?

Help me understand this please, need a speedo and odometer.
there are people that counterfeit them, here's a thread about it.
http://forums.clubrsx.com/showthread.php?t=981266&highlight=
 

·
NvUS East Coast
Joined
·
185 Posts
Hey QuickWrench. Ik I'm bringing back an old thread but I'm experiencing the same symptoms. I am 120% positive that my kpro is real as I sent it out to hondata myself for the v4 upgrade. I have slow gas gauge, and Speedo was not reading at all but now it's stuck at a constant 50. Any luck resolving this?
 
1 - 12 of 12 Posts
Top